Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2025 - 23:00 NZDT
Scheduled
We will be undergoing scheduled maintenance during this time. Some customers may experience several drops in connection during this outage window, if an outage lasts longer than 30 minutes please contact us at help@purelink.nz
Posted Oct 01, 2025 - 16:25 NZDT
This scheduled maintenance affected: Core Network, PureLink Wireless, PureLink 4G Wireless and PureLink Fibre (Tuatahi, Chorus, Enable).