Degraded Service - Morrinsville area

Incident Report for PureLink

Resolved

This incident has been resolved.
Posted Jun 07, 2026 - 16:14 NZST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 07, 2026 - 15:19 NZST

Identified

Some customers may be experiencing slower speeds or intermittent connectivity in the Morrinsville area. Our team is investigating the issue and will provide updates as we work to resolve it.
Posted Jun 07, 2026 - 13:06 NZST
This incident affected: PureLink Wireless.