Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 03, 2025 - 22:25 NZDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 03, 2025 - 22:00 NZDT
Scheduled
Tuatahi is performing maintenance on their fibre network between Hamilton and Raglan, all services with all providers will incur an outage of up to 50 minutes in this scheduled outage window. This affect PureLink Wireless and Fibre customers in the Raglan area
Posted Apr 03, 2025 - 09:57 NZDT
This scheduled maintenance affected: PureLink Fibre (Tuatahi) and PureLink Wireless.