Due to weather conditions, todays upgrades have been cancelled.
Posted Nov 20, 2024 - 09:22 NZDT
Scheduled
We are performing some hardware upgrades on our Wireless network covering Whatawhata. You may experience multiple service interruptions; however these should last no longer than 15 minutes. If you have an outage that lasts longer than 1 hour, please contact us on 0800 100 714.
Posted Nov 11, 2024 - 15:48 NZDT
This scheduled maintenance affected: PureLink Wireless.