Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2026 - 23:00 NZST
Scheduled
During this Maintenance Window Tuatahi First Fibre will be completing upgrades to their core network. Customers on the Tuatahi network can expect an outage to their internet services for up to 15 minutes during this maintenance window.
Posted Jun 18, 2026 - 10:04 NZST
This scheduled maintenance affected: PureLink Fibre (Tuatahi).